Test
Incident Report for Disposable-mailbox.eu
Resolved
This incident has been resolved.
Posted Nov 26, 2021 - 08:22 CET
Update
We are continuing to monitor for any further issues.
Posted Nov 26, 2021 - 08:22 CET
Monitoring
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Nov 26, 2021 - 08:20 CET
Update
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Nov 26, 2021 - 08:19 CET
Investigating
Investigating Mail Deliverly
Posted Nov 26, 2021 - 08:16 CET